summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorLibravatar Héctor Ramón Jiménez <hector0193@gmail.com>2022-02-11 17:51:33 +0700
committerLibravatar Héctor Ramón Jiménez <hector0193@gmail.com>2022-02-11 17:51:33 +0700
commit66d69b5c9a183091e05e82bbe21b3203f75c1b18 (patch)
tree949bf0e2d2948d6f405c78b97f26929d3f008f56 /Cargo.toml
parent897188317b5875cc00a0f1c797790df8ac13687f (diff)
downloadiced-66d69b5c9a183091e05e82bbe21b3203f75c1b18.tar.gz
iced-66d69b5c9a183091e05e82bbe21b3203f75c1b18.tar.bz2
iced-66d69b5c9a183091e05e82bbe21b3203f75c1b18.zip
Expose `iced_pure` through a `pure` feature in `iced`
Besides exposing the `iced_pure` crate, enabling the `pure` feature also provides pure versions of both the `Application` and `Sandbox` traits! :tada:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml3
1 files changed, 3 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 1918d8b4..1527c373 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -44,6 +44,8 @@ async-std = ["iced_futures/async-std"]
smol = ["iced_futures/smol"]
# Enables advanced color conversion via `palette`
palette = ["iced_core/palette"]
+# Enables pure, virtual widgets in the `pure` module
+pure = ["iced_pure"]
[badges]
maintenance = { status = "actively-developed" }
@@ -98,6 +100,7 @@ iced_futures = { version = "0.3", path = "futures" }
iced_winit = { version = "0.3", path = "winit" }
iced_glutin = { version = "0.2", path = "glutin", optional = true }
iced_glow = { version = "0.2", path = "glow", optional = true }
+iced_pure = { version = "0.1", path = "pure", optional = true }
thiserror = "1.0"
[target.'cfg(not(target_arch = "wasm32"))'.dependencies]