summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorLibravatar Clark Moody <clark@clarkmoody.com>2020-03-31 12:11:37 -0500
committerLibravatar Clark Moody <clark@clarkmoody.com>2020-04-24 15:13:22 -0500
commit63933e26d2ffd530fc1d8c9a7d7b94927c0e8cc8 (patch)
tree1eb03212ddfc1f6bf1f3393e382f299ec77b3d71 /Cargo.toml
parent0ff3cbf543e84b1e4d1965efe3d6cce3b1fb5900 (diff)
downloadiced-63933e26d2ffd530fc1d8c9a7d7b94927c0e8cc8.tar.gz
iced-63933e26d2ffd530fc1d8c9a7d7b94927c0e8cc8.tar.bz2
iced-63933e26d2ffd530fc1d8c9a7d7b94927c0e8cc8.zip
Add `palette` dependency behind "colors" feature flag
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml3
1 files changed, 3 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 9c52ea8f..7f6e1f0f 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -24,6 +24,8 @@ debug = ["iced_winit/debug"]
tokio = ["iced_futures/tokio"]
# Enables `async-std` as the `executor::Default` on native platforms
async-std = ["iced_futures/async-std"]
+# Enables advanced color conversion via `palette`
+colors = ["iced_core/colors"]
[badges]
maintenance = { status = "actively-developed" }
@@ -57,6 +59,7 @@ members = [
]
[dependencies]
+iced_core = { version = "0.1", path = "core" }
iced_futures = { version = "0.1", path = "futures" }
[target.'cfg(not(target_arch = "wasm32"))'.dependencies]