summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorLibravatar Héctor Ramón <hector@hecrj.dev>2024-07-17 13:00:00 +0200
committerLibravatar GitHub <noreply@github.com>2024-07-17 13:00:00 +0200
commit616689ca54942a13aac3615e571ae995ad4571b6 (patch)
tree763d8926cfa2be97dffa858a04036e207fd06ec8 /Cargo.toml
parentb518e30610fa53691c727852f70b497dd19cfc7a (diff)
downloadiced-616689ca54942a13aac3615e571ae995ad4571b6.tar.gz
iced-616689ca54942a13aac3615e571ae995ad4571b6.tar.bz2
iced-616689ca54942a13aac3615e571ae995ad4571b6.zip
Update `cosmic-text` and `resvg` (#2416)
* Update `cosmic-text`, `glyphon`, and `resvg` * Fix slow font fallback with `Shaping::Basic` in `cosmic-text` * Update `cosmic-text` and `resvg` * Update `cosmic-text` * Fix `SelectAll` action in `editor` * Fix some panics in `graphics::text::editor` * Remove empty `if` statement in `tiny_skia::vector` * Update `cosmic-text`, `glyphon`, and `rustc-hash`
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml8
1 files changed, 4 insertions, 4 deletions
diff --git a/Cargo.toml b/Cargo.toml
index b85900cf..bc566bf6 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -138,11 +138,11 @@ async-std = "1.0"
bitflags = "2.0"
bytemuck = { version = "1.0", features = ["derive"] }
bytes = "1.6"
-cosmic-text = "0.10"
+cosmic-text = "0.12"
dark-light = "1.0"
futures = "0.3"
glam = "0.25"
-glyphon = { git = "https://github.com/hecrj/glyphon.git", rev = "f07e7bab705e69d39a5e6e52c73039a93c4552f8" }
+glyphon = { git = "https://github.com/hecrj/glyphon.git", rev = "feef9f5630c2adb3528937e55f7bfad2da561a65" }
guillotiere = "0.6"
half = "2.2"
image = "0.24"
@@ -157,8 +157,8 @@ ouroboros = "0.18"
palette = "0.7"
qrcode = { version = "0.13", default-features = false }
raw-window-handle = "0.6"
-resvg = "0.36"
-rustc-hash = "1.0"
+resvg = "0.42"
+rustc-hash = "2.0"
smol = "1.0"
smol_str = "0.2"
softbuffer = "0.4"