summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorLibravatar Héctor Ramón Jiménez <hector@hecrj.dev>2024-04-07 08:11:42 +0200
committerLibravatar Héctor Ramón Jiménez <hector@hecrj.dev>2024-04-07 08:11:42 +0200
commit5ffea8ddef1b966286c14a3294f501201d9edc70 (patch)
tree5014a1e4550a77c8e67e2470f63b3765283f83e6 /Cargo.toml
parenta699348bf3c7af5622b7cbb0b8f8b6bb9b16a22a (diff)
downloadiced-5ffea8ddef1b966286c14a3294f501201d9edc70.tar.gz
iced-5ffea8ddef1b966286c14a3294f501201d9edc70.tar.bz2
iced-5ffea8ddef1b966286c14a3294f501201d9edc70.zip
Add a simple `wgpu` benchmark using `criterion`
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml9
1 files changed, 9 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index b033cf33..def40bd5 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -164,3 +164,12 @@ wgpu = "0.19"
winapi = "0.3"
window_clipboard = "0.4.1"
winit = { git = "https://github.com/iced-rs/winit.git", rev = "592bd152f6d5786fae7d918532d7db752c0d164f" }
+
+[dev-dependencies]
+criterion = "0.5"
+iced_wgpu.workspace = true
+
+[[bench]]
+name = "wgpu"
+harness = false
+required-features = ["canvas"]