summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorLibravatar Héctor Ramón Jiménez <hector@hecrj.dev>2024-04-07 12:42:12 +0200
committerLibravatar Héctor Ramón Jiménez <hector@hecrj.dev>2024-04-07 12:42:12 +0200
commit5cd98f069dea8720bca7748d6c12fa410cbe79b5 (patch)
tree99ce1271cb61c0afa84908b7bd52a94f2b2a652d /Cargo.toml
parenta865b380026ce8c26b818e8e94ea14cb930865a3 (diff)
downloadiced-5cd98f069dea8720bca7748d6c12fa410cbe79b5.tar.gz
iced-5cd98f069dea8720bca7748d6c12fa410cbe79b5.tar.bz2
iced-5cd98f069dea8720bca7748d6c12fa410cbe79b5.zip
Use built-in `[lints]` table in `Cargo.toml`
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml42
1 files changed, 35 insertions, 7 deletions
diff --git a/Cargo.toml b/Cargo.toml
index def40bd5..2b6a0d03 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -10,6 +10,9 @@ homepage.workspace = true
categories.workspace = true
keywords.workspace = true
+[lints]
+workspace = true
+
[package.metadata.docs.rs]
rustdoc-args = ["--cfg", "docsrs"]
all-features = true
@@ -74,6 +77,15 @@ thiserror.workspace = true
image.workspace = true
image.optional = true
+[dev-dependencies]
+criterion = "0.5"
+iced_wgpu.workspace = true
+
+[[bench]]
+name = "wgpu"
+harness = false
+required-features = ["canvas"]
+
[profile.release-opt]
inherits = "release"
codegen-units = 1
@@ -165,11 +177,27 @@ winapi = "0.3"
window_clipboard = "0.4.1"
winit = { git = "https://github.com/iced-rs/winit.git", rev = "592bd152f6d5786fae7d918532d7db752c0d164f" }
-[dev-dependencies]
-criterion = "0.5"
-iced_wgpu.workspace = true
+[workspace.lints.rust]
+rust_2018_idioms = "forbid"
+missing_debug_implementations = "deny"
+missing_docs = "deny"
+unsafe_code = "deny"
+unused_results = "deny"
-[[bench]]
-name = "wgpu"
-harness = false
-required-features = ["canvas"]
+[workspace.lints.clippy]
+type-complexity = "allow"
+semicolon_if_nothing_returned = "deny"
+trivially-copy-pass-by-ref = "deny"
+default_trait_access = "deny"
+match-wildcard-for-single-variants = "deny"
+redundant-closure-for-method-calls = "deny"
+filter_map_next = "deny"
+manual_let_else = "deny"
+unused_async = "deny"
+from_over_into = "deny"
+needless_borrow = "deny"
+new_without_default = "deny"
+useless_conversion = "deny"
+
+[workspace.lints.rustdoc]
+broken_intra_doc_links = "forbid"