summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorLibravatar Héctor Ramón Jiménez <hector0193@gmail.com>2023-02-24 23:24:48 +0100
committerLibravatar Héctor Ramón Jiménez <hector0193@gmail.com>2023-02-24 23:24:48 +0100
commit5100b5d0a1f654ec1254b7765ceadfb9091d6939 (patch)
treeac33dc79803af7040659380c0c94440b29e93e77 /Cargo.toml
parent368cadd25a8b57ee5c41e45d1abe8d1dfb194c69 (diff)
downloadiced-5100b5d0a1f654ec1254b7765ceadfb9091d6939.tar.gz
iced-5100b5d0a1f654ec1254b7765ceadfb9091d6939.tar.bz2
iced-5100b5d0a1f654ec1254b7765ceadfb9091d6939.zip
Introduce `iced_renderer` subcrate featuring runtime renderer fallback
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml14
1 files changed, 5 insertions, 9 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 551e12ac..d999febe 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -13,9 +13,9 @@ categories = ["gui"]
[features]
# Enables the `Image` widget
-image = ["iced_wgpu/image", "image_rs"]
+image = ["iced_renderer/image", "image_rs"]
# Enables the `Svg` widget
-svg = ["iced_wgpu/svg"]
+svg = ["iced_renderer/svg"]
# Enables the `Canvas` widget
canvas = ["iced_graphics/canvas"]
# Enables the `QRCode` widget
@@ -35,7 +35,7 @@ system = ["iced_winit/system"]
# Enables chrome traces
chrome-trace = [
"iced_winit/chrome-trace",
- "iced_wgpu/tracing",
+ "iced_renderer/tracing",
]
[badges]
@@ -48,6 +48,7 @@ members = [
"graphics",
"lazy",
"native",
+ "renderer",
"style",
"wgpu",
"winit",
@@ -59,6 +60,7 @@ iced_core = { version = "0.8", path = "core" }
iced_futures = { version = "0.6", path = "futures" }
iced_native = { version = "0.9", path = "native" }
iced_graphics = { version = "0.7", path = "graphics" }
+iced_renderer = { version = "0.1", path = "renderer" }
iced_winit = { version = "0.8", path = "winit", features = ["application"] }
thiserror = "1.0"
@@ -67,12 +69,6 @@ version = "0.24"
package = "image"
optional = true
-[target.'cfg(not(target_arch = "wasm32"))'.dependencies]
-iced_wgpu = { version = "0.9", path = "wgpu" }
-
-[target.'cfg(target_arch = "wasm32")'.dependencies]
-iced_wgpu = { version = "0.9", path = "wgpu", features = ["webgl"] }
-
[package.metadata.docs.rs]
rustdoc-args = ["--cfg", "docsrs"]
features = ["image", "svg", "canvas", "qr_code"]