summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorLibravatar Ian Douglas Scott <idscott@system76.com>2022-11-03 14:53:22 -0700
committerLibravatar Ian Douglas Scott <idscott@system76.com>2022-11-03 14:53:22 -0700
commit4d42ca2452cd270dfcfbdb03836c5857a3c28f73 (patch)
treeee99d133934aeefaf4f70380e89d26a71497b727 /Cargo.toml
parentd222b5c8b0befab665c20ba0112b28199df0ae44 (diff)
downloadiced-4d42ca2452cd270dfcfbdb03836c5857a3c28f73.tar.gz
iced-4d42ca2452cd270dfcfbdb03836c5857a3c28f73.tar.bz2
iced-4d42ca2452cd270dfcfbdb03836c5857a3c28f73.zip
Combine `glow_default_system_font` and `default_system_font` features
Apparently "weak dependency features" have been stable since Rust 1.60.0, allowing a feature to enable a feature of a dependency only if that dependency is enabled elsewhere. So having a separate feature for this with glow is unnecessary now. Also remove the `resolver` setting which is redundant on edition 2021.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml5
1 files changed, 1 insertions, 4 deletions
diff --git a/Cargo.toml b/Cargo.toml
index f7d578ba..0c936ac5 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -10,7 +10,6 @@ documentation = "https://docs.rs/iced"
readme = "README.md"
keywords = ["gui", "ui", "graphics", "interface", "widgets"]
categories = ["gui"]
-resolver = "2"
[features]
default = ["wgpu"]
@@ -25,11 +24,9 @@ qr_code = ["iced_graphics/qr_code"]
# Enables the `iced_wgpu` renderer
wgpu = ["iced_wgpu"]
# Enables using system fonts
-default_system_font = ["iced_wgpu/default_system_font"]
+default_system_font = ["iced_wgpu?/default_system_font", "iced_glow?/default_system_font"]
# Enables the `iced_glow` renderer. Overrides `iced_wgpu`
glow = ["iced_glow", "iced_glutin"]
-# Enables using system fonts for `iced_glow`
-glow_default_system_font = ["iced_glow/default_system_font"]
# Enables a debug view in native platforms (press F12)
debug = ["iced_winit/debug"]
# Enables `tokio` as the `executor::Default` on native platforms