summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorLibravatar bungoboingo <shankern@protonmail.com>2022-12-20 20:41:09 -0800
committerLibravatar Héctor Ramón Jiménez <hector0193@gmail.com>2023-01-09 18:52:38 +0100
commit4b6d3797d43acb1d78a292a7ec712a0be7c8f6a2 (patch)
tree1208a2c5b16a5e67093677df3a2d6bf159bff0f9 /Cargo.toml
parentc5cd236b7380c3689792934aeaecd2942713fa67 (diff)
downloadiced-4b6d3797d43acb1d78a292a7ec712a0be7c8f6a2.tar.gz
iced-4b6d3797d43acb1d78a292a7ec712a0be7c8f6a2.tar.bz2
iced-4b6d3797d43acb1d78a292a7ec712a0be7c8f6a2.zip
Restructured everything to make profiling a feature of iced_winit.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml13
1 files changed, 5 insertions, 8 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 2cedb1b6..681aae5e 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -39,13 +39,12 @@ smol = ["iced_futures/smol"]
palette = ["iced_core/palette"]
# Enables querying system information
system = ["iced_winit/system"]
-# Enables tracing with Chrome
-trace_chrome = [
- "iced_winit/trace",
- "iced_wgpu?/trace",
- "iced_glow?/trace",
+# Enables chrome traces
+chrome-trace = [
+ "iced_winit/chrome-trace",
"iced_glutin?/trace",
- "iced_profiling/tracing-chrome"
+ "iced_wgpu?/tracing",
+ "iced_glow?/tracing",
]
[badges]
@@ -59,7 +58,6 @@ members = [
"glow",
"glutin",
"lazy",
- "profiling",
"native",
"style",
"wgpu",
@@ -75,7 +73,6 @@ iced_graphics = { version = "0.5", path = "graphics" }
iced_winit = { version = "0.6", path = "winit", features = ["application"] }
iced_glutin = { version = "0.5", path = "glutin", optional = true }
iced_glow = { version = "0.5", path = "glow", optional = true }
-iced_profiling = { version = "0.1.0", path = "profiling", optional = true }
thiserror = "1.0"
[dependencies.image_rs]