summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorLibravatar Héctor Ramón Jiménez <hector@hecrj.dev>2024-07-18 14:34:00 +0200
committerLibravatar Héctor Ramón Jiménez <hector@hecrj.dev>2024-07-18 14:34:00 +0200
commit47b7a36f36b99e346909390621b04f6691ff46d4 (patch)
treeab3d5c7ca7c81eb14fd5e2b0332e63fe68a6a7f8 /Cargo.toml
parentaa62fa2ce992949d20ddbe8683ed2be0d922a568 (diff)
downloadiced-47b7a36f36b99e346909390621b04f6691ff46d4.tar.gz
iced-47b7a36f36b99e346909390621b04f6691ff46d4.tar.bz2
iced-47b7a36f36b99e346909390621b04f6691ff46d4.zip
Create `markdown` widget helpers in `iced_widget`
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml5
1 files changed, 4 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index bc566bf6..d301b36d 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -34,6 +34,8 @@ svg = ["iced_widget/svg"]
canvas = ["iced_widget/canvas"]
# Enables the `QRCode` widget
qr_code = ["iced_widget/qr_code"]
+# Enables the `markdown` widget
+markdown = ["iced_widget/markdown"]
# Enables lazy widgets
lazy = ["iced_widget/lazy"]
# Enables a debug view in native platforms (press F12)
@@ -51,7 +53,7 @@ web-colors = ["iced_renderer/web-colors"]
# Enables the WebGL backend, replacing WebGPU
webgl = ["iced_renderer/webgl"]
# Enables the syntax `highlighter` module
-highlighter = ["iced_highlighter"]
+highlighter = ["iced_highlighter", "iced_widget/highlighter"]
# Enables experimental multi-window support.
multi-window = ["iced_winit/multi-window"]
# Enables the advanced module
@@ -155,6 +157,7 @@ num-traits = "0.2"
once_cell = "1.0"
ouroboros = "0.18"
palette = "0.7"
+pulldown-cmark = "0.11"
qrcode = { version = "0.13", default-features = false }
raw-window-handle = "0.6"
resvg = "0.42"