summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorLibravatar Gigas002 <24297712+Gigas002@users.noreply.github.com>2024-03-24 11:13:45 +0900
committerLibravatar GitHub <noreply@github.com>2024-03-24 11:13:45 +0900
commit4334e63ba1dd88b367f3b7f2790b7869d11d12c0 (patch)
tree7a02d84426a54a5a5283f5ad101cc803442998fd /Cargo.toml
parentf3a1c785b2743e9c48c3d28df0c6772ce579d7c8 (diff)
parent3013463baa71504488a20436beb3db87ecb66df0 (diff)
downloadiced-4334e63ba1dd88b367f3b7f2790b7869d11d12c0.tar.gz
iced-4334e63ba1dd88b367f3b7f2790b7869d11d12c0.tar.bz2
iced-4334e63ba1dd88b367f3b7f2790b7869d11d12c0.zip
Merge branch 'iced-rs:master' into viewer_content_fit
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml8
1 files changed, 6 insertions, 2 deletions
diff --git a/Cargo.toml b/Cargo.toml
index f446e2af..b82c0f67 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -18,7 +18,7 @@ all-features = true
maintenance = { status = "actively-developed" }
[features]
-default = ["wgpu", "fira-sans"]
+default = ["wgpu", "fira-sans", "auto-detect-theme"]
# Enable the `wgpu` GPU-accelerated renderer backend
wgpu = ["iced_renderer/wgpu", "iced_widget/wgpu"]
# Enables the `Image` widget
@@ -53,8 +53,11 @@ multi-window = ["iced_winit/multi-window"]
advanced = []
# Enables embedding Fira Sans as the default font on Wasm builds
fira-sans = ["iced_renderer/fira-sans"]
+# Enables auto-detecting light/dark mode for the built-in theme
+auto-detect-theme = ["iced_core/auto-detect-theme"]
[dependencies]
+iced_core.workspace = true
iced_futures.workspace = true
iced_renderer.workspace = true
iced_widget.workspace = true
@@ -121,6 +124,7 @@ async-std = "1.0"
bitflags = "2.0"
bytemuck = { version = "1.0", features = ["derive"] }
cosmic-text = "0.10"
+dark-light = "1.0"
futures = "0.3"
glam = "0.25"
glyphon = "0.5"
@@ -158,4 +162,4 @@ web-time = "0.2"
wgpu = "0.19"
winapi = "0.3"
window_clipboard = "0.4.1"
-winit = { git = "https://github.com/iced-rs/winit.git", rev = "b91e39ece2c0d378c3b80da7f3ab50e17bb798a5" }
+winit = { git = "https://github.com/iced-rs/winit.git", rev = "592bd152f6d5786fae7d918532d7db752c0d164f" }