summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorLibravatar Héctor Ramón Jiménez <hector0193@gmail.com>2023-03-04 05:37:11 +0100
committerLibravatar Héctor Ramón Jiménez <hector0193@gmail.com>2023-03-04 05:37:11 +0100
commit3a0d34c0240f4421737a6a08761f99d6f8140d02 (patch)
treec9a4a6b8e9c1db1b8fcd05bc98e3f131d5ef4bd5 /Cargo.toml
parentc54409d1711e1f615c7ea4b02c082954e340632a (diff)
downloadiced-3a0d34c0240f4421737a6a08761f99d6f8140d02.tar.gz
iced-3a0d34c0240f4421737a6a08761f99d6f8140d02.tar.bz2
iced-3a0d34c0240f4421737a6a08761f99d6f8140d02.zip
Create `iced_widget` subcrate and re-organize the whole codebase
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml29
1 files changed, 11 insertions, 18 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 28938df9..49a52311 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -13,13 +13,15 @@ categories = ["gui"]
[features]
# Enables the `Image` widget
-image = ["iced_renderer/image", "image_rs"]
+image = ["iced_widget/image", "image_rs"]
# Enables the `Svg` widget
-svg = ["iced_renderer/svg"]
+svg = ["iced_widget/svg"]
# Enables the `Canvas` widget
-canvas = ["iced_renderer/geometry"]
+canvas = ["iced_widget/canvas"]
# Enables the `QRCode` widget
-qr_code = ["canvas", "qrcode"]
+qr_code = ["iced_widget/qr_code"]
+# Enables lazy widgets
+lazy = ["iced_widget/lazy"]
# Enables a debug view in native platforms (press F12)
debug = ["iced_winit/debug"]
# Enables `tokio` as the `executor::Default` on native platforms
@@ -32,11 +34,8 @@ smol = ["iced_futures/smol"]
palette = ["iced_core/palette"]
# Enables querying system information
system = ["iced_winit/system"]
-# Enables chrome traces
-chrome-trace = [
- "iced_winit/chrome-trace",
- "iced_renderer/tracing",
-]
+# Enables the advanced module
+advanced = []
[badges]
maintenance = { status = "actively-developed" }
@@ -46,12 +45,12 @@ members = [
"core",
"futures",
"graphics",
- "lazy",
"native",
"renderer",
"style",
"tiny_skia",
"wgpu",
+ "widget",
"winit",
"examples/*",
]
@@ -59,21 +58,15 @@ members = [
[dependencies]
iced_core = { version = "0.8", path = "core" }
iced_futures = { version = "0.6", path = "futures" }
-iced_native = { version = "0.9", path = "native" }
-iced_renderer = { version = "0.1", path = "renderer" }
+iced_widget = { version = "0.1", path = "widget" }
iced_winit = { version = "0.8", path = "winit", features = ["application"] }
-thiserror = "1.0"
+thiserror = "1"
[dependencies.image_rs]
version = "0.24"
package = "image"
optional = true
-[dependencies.qrcode]
-version = "0.12"
-optional = true
-default-features = false
-
[package.metadata.docs.rs]
rustdoc-args = ["--cfg", "docsrs"]
features = ["image", "svg", "canvas", "qr_code"]