summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorLibravatar Héctor Ramón <hector0193@gmail.com>2022-07-14 18:19:19 +0200
committerLibravatar GitHub <noreply@github.com>2022-07-14 18:19:19 +0200
commit387b2d09912be8b26cfc775d7922fcf5042a99db (patch)
tree5ad3a8783858d926726999546e8acfa478cf6b4a /Cargo.toml
parente187d6ce7bd5e984950fa3e8aa36ccb1337edc9c (diff)
parent7022090a97c19c8175ae103a6d7bea8a1055c301 (diff)
downloadiced-387b2d09912be8b26cfc775d7922fcf5042a99db.tar.gz
iced-387b2d09912be8b26cfc775d7922fcf5042a99db.tar.bz2
iced-387b2d09912be8b26cfc775d7922fcf5042a99db.zip
Merge pull request #1346 from Luni-4/reduce-binaries
Add profile release
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml10
1 files changed, 10 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 9d90ca0d..56b4d06a 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -121,3 +121,13 @@ iced_wgpu = { version = "0.5", path = "wgpu", features = ["webgl"], optional = t
[package.metadata.docs.rs]
rustdoc-args = ["--cfg", "docsrs"]
features = ["image", "svg", "canvas", "qr_code", "pure"]
+
+[profile.release-opt]
+inherits = "release"
+codegen-units = 1
+debug = false
+lto = true
+incremental = false
+opt-level = 3
+overflow-checks = false
+strip = "debuginfo"