summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorLibravatar Héctor Ramón Jiménez <hector@hecrj.dev>2024-02-20 03:20:58 +0100
committerLibravatar Héctor Ramón Jiménez <hector@hecrj.dev>2024-02-20 03:20:58 +0100
commit35e2049ee668791f67b5325fc156b8c042d26d49 (patch)
tree3db828501fedac26342c41fcec05d0e9a7477f0f /Cargo.toml
parent0c7f4eaab5b5c19b914a8eed548349388bbd6300 (diff)
downloadiced-35e2049ee668791f67b5325fc156b8c042d26d49.tar.gz
iced-35e2049ee668791f67b5325fc156b8c042d26d49.tar.bz2
iced-35e2049ee668791f67b5325fc156b8c042d26d49.zip
Embed Fira Sans font on Wasm builds by default
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml4
1 files changed, 3 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index ef7eae61..7d275b31 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -18,7 +18,7 @@ all-features = true
maintenance = { status = "actively-developed" }
[features]
-default = ["wgpu"]
+default = ["wgpu", "fira-sans"]
# Enable the `wgpu` GPU-accelerated renderer backend
wgpu = ["iced_renderer/wgpu", "iced_widget/wgpu"]
# Enables the `Image` widget
@@ -53,6 +53,8 @@ highlighter = ["iced_highlighter"]
multi-window = ["iced_winit/multi-window"]
# Enables the advanced module
advanced = []
+# Enables embedding Fira Sans as the default font on Wasm builds
+fira-sans = ["iced_renderer/fira-sans"]
[dependencies]
iced_core.workspace = true