diff options
author | 2022-05-04 17:19:28 +0200 | |
---|---|---|
committer | 2022-05-04 17:19:28 +0200 | |
commit | 27fdc707562d4e229f07ed9496ed5d64f4e108bc (patch) | |
tree | 8a87286f0ccd125df1c2b5c597c2d2805ceb27c5 /Cargo.toml | |
parent | a97c520c814a6d3cc538537791be39e0c3182d6d (diff) | |
parent | 02914e5e68d1fbaad53483cd32c74d9ac448d1eb (diff) | |
download | iced-27fdc707562d4e229f07ed9496ed5d64f4e108bc.tar.gz iced-27fdc707562d4e229f07ed9496ed5d64f4e108bc.tar.bz2 iced-27fdc707562d4e229f07ed9496ed5d64f4e108bc.zip |
Merge branch 'master' into dev/system-information
Diffstat (limited to 'Cargo.toml')
-rw-r--r-- | Cargo.toml | 25 |
1 files changed, 13 insertions, 12 deletions
@@ -1,6 +1,6 @@ [package] name = "iced" -version = "0.3.0" +version = "0.4.2" authors = ["Héctor Ramón Jiménez <hector0193@gmail.com>"] edition = "2021" description = "A cross-platform GUI library inspired by Elm" @@ -96,26 +96,27 @@ members = [ "examples/pure/pane_grid", "examples/pure/pick_list", "examples/pure/todos", + "examples/pure/tooltip", "examples/pure/tour", ] [dependencies] -iced_core = { version = "0.4", path = "core" } -iced_futures = { version = "0.3", path = "futures" } -iced_native = { version = "0.4", path = "native" } -iced_graphics = { version = "0.2", path = "graphics" } -iced_winit = { version = "0.3", path = "winit" } -iced_glutin = { version = "0.2", path = "glutin", optional = true } -iced_glow = { version = "0.2", path = "glow", optional = true } -iced_pure = { version = "0.1", path = "pure", optional = true } +iced_core = { version = "0.5", path = "core" } +iced_futures = { version = "0.4", path = "futures" } +iced_native = { version = "0.5", path = "native" } +iced_graphics = { version = "0.3", path = "graphics" } +iced_winit = { version = "0.4", path = "winit" } +iced_glutin = { version = "0.3", path = "glutin", optional = true } +iced_glow = { version = "0.3", path = "glow", optional = true } +iced_pure = { version = "0.2", path = "pure", optional = true } thiserror = "1.0" [target.'cfg(not(target_arch = "wasm32"))'.dependencies] -iced_wgpu = { version = "0.4", path = "wgpu", optional = true } +iced_wgpu = { version = "0.5", path = "wgpu", optional = true } [target.'cfg(target_arch = "wasm32")'.dependencies] -iced_wgpu = { version = "0.4", path = "wgpu", features = ["webgl"], optional = true } +iced_wgpu = { version = "0.5", path = "wgpu", features = ["webgl"], optional = true } [package.metadata.docs.rs] rustdoc-args = ["--cfg", "docsrs"] -features = ["image", "svg", "canvas", "qr_code"] +features = ["image", "svg", "canvas", "qr_code", "pure"] |