summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorLibravatar Dispersia <dispersias@gmail.com>2021-04-12 22:06:16 -0700
committerLibravatar Dispersia <dispersias@gmail.com>2021-04-12 22:06:16 -0700
commitc719091c3d7b5f71899530437fde9b512bc2b0f3 (patch)
tree9426b5f2d6b74e7f1254ccd0bb64af246368fad9 /Cargo.toml
parent9a2c78c4059d2be37d10adda397fb6e64f38ac02 (diff)
downloadiced-c719091c3d7b5f71899530437fde9b512bc2b0f3.tar.gz
iced-c719091c3d7b5f71899530437fde9b512bc2b0f3.tar.bz2
iced-c719091c3d7b5f71899530437fde9b512bc2b0f3.zip
Add staging belt fix
Diffstat (limited to '')
-rw-r--r--Cargo.toml12
1 files changed, 12 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 6d894eba..19f25d9d 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -11,6 +11,18 @@ readme = "README.md"
keywords = ["gui", "ui", "graphics", "interface", "widgets"]
categories = ["gui"]
+[patch."https://github.com/gfx-rs/wgpu"]
+wgpu-types = { git = "https://github.com/Dispersia/wgpu" }
+wgpu-core = { git = "https://github.com/Dispersia/wgpu" }
+
+[patch."https://github.com/gfx-rs/wgpu-rs"]
+wgpu = { git = "https://github.com/Dispersia/wgpu-rs" }
+
+[patch.crates-io]
+wgpu-types = { git = "https://github.com/Dispersia/wgpu" }
+wgpu-core = { git = "https://github.com/Dispersia/wgpu" }
+wgpu = { git = "https://github.com/Dispersia/wgpu-rs" }
+
[features]
default = ["wgpu", "default_system_font"]
# Enables the `iced_wgpu` renderer