diff options
author | 2023-09-12 18:15:00 -0400 | |
---|---|---|
committer | 2023-11-11 03:40:22 +0100 | |
commit | 98e088e731e6fbd5b5035033ae61bda823ced988 (patch) | |
tree | 4e12f49f37ad6d5c6dffd06bc7fabc05930db3e1 /Cargo.toml | |
parent | 751ea77c29f6eb3d00f45f0a04c833a1d03a425c (diff) | |
download | iced-98e088e731e6fbd5b5035033ae61bda823ced988.tar.gz iced-98e088e731e6fbd5b5035033ae61bda823ced988.tar.bz2 iced-98e088e731e6fbd5b5035033ae61bda823ced988.zip |
Migrate twox-hash -> xxhash_rust. Switch to Xxh3 for better performance.
xxhash-rust is more maintained, built against `::core`, so no workaround for wasm is necessary. Switch to Xxh3 for better performance, which shows when loading/hashing image buffers.
Diffstat (limited to '')
-rw-r--r-- | Cargo.toml | 2 |
1 files changed, 1 insertions, 1 deletions
@@ -150,7 +150,7 @@ thiserror = "1.0" tiny-skia = "0.10" tokio = "1.0" tracing = "0.1" -twox-hash = { version = "1.0", default-features = false } +xxhash-rust = { version = "0.8.7", default-features = false, features = ["xxh3"] } unicode-segmentation = "1.0" wasm-bindgen-futures = "0.4" wasm-timer = "0.2" |