aboutsummaryrefslogtreecommitdiffstats
path: root/askama_shared/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--askama_shared/Cargo.toml15
1 files changed, 11 insertions, 4 deletions
diff --git a/askama_shared/Cargo.toml b/askama_shared/Cargo.toml
index 733416a..15a3243 100644
--- a/askama_shared/Cargo.toml
+++ b/askama_shared/Cargo.toml
@@ -9,11 +9,18 @@ license = "MIT/Apache-2.0"
workspace = ".."
edition = "2018"
+[features]
+default = ["config", "humansize", "num-traits"]
+config = ["serde", "toml"]
+json = ["serde", "serde_json"]
+yaml = ["serde", "serde_yaml"]
+
[dependencies]
askama_escape = { version = "0.2.0", path = "../askama_escape" }
-humansize = "1.1.0"
-num-traits = "0.2.6"
-serde = { version = "1.0", features = ["derive"] }
+humansize = { version = "1.1.0", optional = true }
+num-traits = { version = "0.2.6", optional = true }
+serde = { version = "1.0", optional = true, features = ["derive"] }
+serde_derive = { version = "1.0", optional = true }
serde_json = { version = "1.0", optional = true }
serde_yaml = { version = "0.8", optional = true }
-toml = "0.5"
+toml = { version = "0.5", optional = true }