aboutsummaryrefslogtreecommitdiffstats
path: root/askama_poem/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'askama_poem/Cargo.toml')
-rw-r--r--askama_poem/Cargo.toml32
1 files changed, 32 insertions, 0 deletions
diff --git a/askama_poem/Cargo.toml b/askama_poem/Cargo.toml
new file mode 100644
index 0000000..20c720b
--- /dev/null
+++ b/askama_poem/Cargo.toml
@@ -0,0 +1,32 @@
+[package]
+name = "askama_poem"
+version = "0.14.0"
+description = "Poem integration for Askama templates"
+documentation = "https://docs.rs/askama"
+keywords = ["markup", "template", "jinja2", "html"]
+categories = ["template-engine"]
+homepage = "https://github.com/djc/askama"
+repository = "https://github.com/djc/askama"
+license = "MIT OR Apache-2.0"
+workspace = ".."
+readme = "README.md"
+edition = "2021"
+rust-version = "1.65"
+
+[dependencies]
+poem = { version = "2.0.0", default-features = false }
+askama = { version = "0.12", path = "../askama", default-features = false, features = ["with-poem"] }
+
+[dev-dependencies]
+poem = { version = "2.0.0", features = ["test"] }
+tokio = "1.0"
+
+[features]
+default = ["askama/default"]
+config = ["askama/config"]
+humansize = ["askama/humansize"]
+markdown = ["askama/markdown"]
+num-traits = ["askama/num-traits"]
+serde-json = ["askama/serde-json"]
+serde-yaml = ["askama/serde-yaml"]
+urlencode = ["askama/urlencode"]