aboutsummaryrefslogtreecommitdiffstats
path: root/askama_parser/fuzz/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--askama_parser/fuzz/Cargo.toml27
1 files changed, 27 insertions, 0 deletions
diff --git a/askama_parser/fuzz/Cargo.toml b/askama_parser/fuzz/Cargo.toml
new file mode 100644
index 0000000..3190e5a
--- /dev/null
+++ b/askama_parser/fuzz/Cargo.toml
@@ -0,0 +1,27 @@
+[package]
+name = "askama_parser-fuzz"
+version = "0.0.0"
+publish = false
+edition = "2021"
+
+[package.metadata]
+cargo-fuzz = true
+
+[dependencies]
+libfuzzer-sys = "0.4"
+
+[dependencies.askama_parser]
+path = ".."
+
+# Prevent this from interfering with workspaces
+[workspace]
+members = ["."]
+
+[profile.release]
+debug = 1
+
+[[bin]]
+name = "fuzz_parser"
+path = "fuzz_targets/fuzz_parser.rs"
+test = false
+doc = false