aboutsummaryrefslogtreecommitdiffstats
path: root/askama_hyper/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'askama_hyper/Cargo.toml')
-rw-r--r--askama_hyper/Cargo.toml33
1 files changed, 33 insertions, 0 deletions
diff --git a/askama_hyper/Cargo.toml b/askama_hyper/Cargo.toml
new file mode 100644
index 0000000..6a7a213
--- /dev/null
+++ b/askama_hyper/Cargo.toml
@@ -0,0 +1,33 @@
+[package]
+name = "askama_hyper"
+version = "0.1.0"
+description = "Hyper integration for Askama templates"
+documentation = "https://docs.rs/askama"
+keywords = ["markup", "template", "jinja2", "html"]
+categories = ["template-engine"]
+homepage = "https://github.com/djc/askama"
+repository = "https://github.com/djc/askama"
+license = "MIT OR Apache-2.0"
+workspace = ".."
+readme = "README.md"
+edition = "2018"
+
+[dependencies]
+askama = { version = "0.11.2", path = "../askama", default-features = false, features = ["with-hyper"] }
+hyper = { version = "0.14", default-features = false }
+
+[dev-dependencies]
+hyper = { version = "0.14", features = ["client"] }
+mime = "0.3"
+routerify = "3"
+tokio = { version = "1", default-features = false, features = ["net", "macros", "rt"] }
+
+[features]
+default = ["askama/default"]
+config = ["askama/config"]
+humansize = ["askama/humansize"]
+markdown = ["askama/markdown"]
+num-traits = ["askama/num-traits"]
+serde-json = ["askama/serde-json"]
+serde-yaml = ["askama/serde-yaml"]
+urlencode = ["askama/urlencode"]