aboutsummaryrefslogtreecommitdiffstats
path: root/testing/Cargo.toml
diff options
context:
space:
mode:
authorLibravatar Ryan McGrath <ryan@rymc.io>2018-07-21 19:10:48 +0000
committerLibravatar Dirkjan Ochtman <dirkjan@ochtman.nl>2018-07-22 14:47:29 +0100
commited98793b506c66723c713991f40c0065557a35d5 (patch)
tree6ab23bf2dab25d63f276de96504f7cb28cb3d9cb /testing/Cargo.toml
parentc860bee5d5934fba6d57cbf815894a5cc8599ad9 (diff)
downloadaskama-ed98793b506c66723c713991f40c0065557a35d5.tar.gz
askama-ed98793b506c66723c713991f40c0065557a35d5.tar.bz2
askama-ed98793b506c66723c713991f40c0065557a35d5.zip
Tests for actix_web
Diffstat (limited to '')
-rw-r--r--testing/Cargo.toml6
1 files changed, 4 insertions, 2 deletions
diff --git a/testing/Cargo.toml b/testing/Cargo.toml
index ff67e2e..6223673 100644
--- a/testing/Cargo.toml
+++ b/testing/Cargo.toml
@@ -9,7 +9,9 @@ default = []
nightly = ["rocket", "rocket_codegen", "askama/with-rocket"]
[dependencies]
-askama = { path = "../askama", version = "*", features = ["with-iron", "serde-json"] }
+actix-web = "0.7"
+askama = { path = "../askama", version = "*", features = ["with-actix-web", "with-iron", "serde-json"] }
+bytes = "0.4"
criterion = "0.2"
iron = "0.6"
rocket = { version = "0.3", optional = true }
@@ -17,7 +19,7 @@ rocket_codegen = { version = "0.3", optional = true }
serde_json = "1.0"
[build-dependencies]
-askama = { path = "../askama", version = "*", features = ["with-iron", "serde-json"] }
+askama = { path = "../askama", version = "*", features = ["with-actix-web", "with-iron", "serde-json"] }
[[bench]]
name = "all"