aboutsummaryrefslogtreecommitdiffstats
path: root/testing/Cargo.toml
diff options
context:
space:
mode:
authorLibravatar Dirkjan Ochtman <dirkjan@ochtman.nl>2017-08-23 16:32:28 +0200
committerLibravatar Dirkjan Ochtman <dirkjan@ochtman.nl>2017-08-23 20:55:45 +0200
commite0300661068f3c8141cdc90fa915f7c61ce3d1ab (patch)
treebf9c3827a6f7c8269f14442e54d79902835f7e9d /testing/Cargo.toml
parentbf51e7264fb4273672430f74ce8c2b16a74d1c38 (diff)
downloadaskama-e0300661068f3c8141cdc90fa915f7c61ce3d1ab.tar.gz
askama-e0300661068f3c8141cdc90fa915f7c61ce3d1ab.tar.bz2
askama-e0300661068f3c8141cdc90fa915f7c61ce3d1ab.zip
Add test for Rocket support
Diffstat (limited to '')
-rw-r--r--testing/Cargo.toml6
1 files changed, 6 insertions, 0 deletions
diff --git a/testing/Cargo.toml b/testing/Cargo.toml
index 6d81db5..8db4cd5 100644
--- a/testing/Cargo.toml
+++ b/testing/Cargo.toml
@@ -5,10 +5,16 @@ authors = ["Dirkjan Ochtman <dirkjan@ochtman.nl>"]
workspace = ".."
build = "build.rs"
+[features]
+default = []
+nightly = ["rocket", "rocket_codegen", "askama/with-rocket"]
+
[dependencies]
iron = "0.5"
serde_json = "1.0"
askama = { path = "../askama", version = "*", features = ["with-iron", "serde-json"] }
+rocket = { version = "0.3", optional = true }
+rocket_codegen = { version = "0.3", optional = true }
[build-dependencies]
askama = { path = "../askama", version = "*", features = ["with-iron", "serde-json"] }