aboutsummaryrefslogtreecommitdiffstats
path: root/testing/Cargo.toml
diff options
context:
space:
mode:
authorLibravatar Dirkjan Ochtman <dirkjan@ochtman.nl>2018-11-04 22:36:45 +0100
committerLibravatar Dirkjan Ochtman <dirkjan@ochtman.nl>2018-11-04 22:36:45 +0100
commit6c442903c6b9656318b13aba0875d204b7427497 (patch)
tree53d7b90577901e2df59d480f08f8753ed10c169a /testing/Cargo.toml
parent8edf5dea2a3f2c5c3a3a13dfa525662ee390e213 (diff)
downloadaskama-6c442903c6b9656318b13aba0875d204b7427497.tar.gz
askama-6c442903c6b9656318b13aba0875d204b7427497.tar.bz2
askama-6c442903c6b9656318b13aba0875d204b7427497.zip
Disable tests that need dependencies by default
Diffstat (limited to '')
-rw-r--r--testing/Cargo.toml19
1 files changed, 12 insertions, 7 deletions
diff --git a/testing/Cargo.toml b/testing/Cargo.toml
index 7c93783..15cbfe2 100644
--- a/testing/Cargo.toml
+++ b/testing/Cargo.toml
@@ -5,22 +5,27 @@ authors = ["Dirkjan Ochtman <dirkjan@ochtman.nl>"]
workspace = ".."
[features]
-default = ["actix"]
-with-rocket = ["rocket", "rocket_codegen", "askama/with-rocket"]
actix = ["actix-web", "bytes", "askama/with-actix-web"]
+default = []
+full = ["actix", "with-iron", "serde-json"]
+serde-json = ["serde_json", "askama/serde-json"]
+with-rocket = ["rocket", "rocket_codegen", "askama/with-rocket"]
+with-iron = ["iron", "askama/with-iron"]
[dependencies]
actix-web = { version = "0.7", optional = true }
-askama = { path = "../askama", version = "*", features = ["with-iron", "serde-json"] }
+askama = { path = "../askama", version = "*" }
bytes = { version = "0.4", optional = true }
-criterion = "0.2"
-iron = "0.6"
+iron = { version = "0.6", optional = true }
rocket = { version = "0.3", optional = true }
rocket_codegen = { version = "0.3", optional = true }
-serde_json = "1.0"
+serde_json = { version = "1.0", optional = true }
[build-dependencies]
-askama = { path = "../askama", version = "*", features = ["with-iron", "serde-json"] }
+askama = { path = "../askama", version = "*" }
+
+[dev-dependencies]
+criterion = "0.2"
[[bench]]
name = "all"