aboutsummaryrefslogtreecommitdiffstats
path: root/askama_shared/Cargo.toml
diff options
context:
space:
mode:
authorLibravatar Dirkjan Ochtman <dirkjan@ochtman.nl>2017-08-27 22:10:42 +0200
committerLibravatar Dirkjan Ochtman <dirkjan@ochtman.nl>2017-08-27 22:10:42 +0200
commit9f3b590206e3dfe33b7129b1c8ff010f60318cf2 (patch)
tree5411864d92ec220d9d4db8d9e40cda6df9b2b16f /askama_shared/Cargo.toml
parentaeac47cee0e14b9fa38c01082876667f0ec8d874 (diff)
downloadaskama-9f3b590206e3dfe33b7129b1c8ff010f60318cf2.tar.gz
askama-9f3b590206e3dfe33b7129b1c8ff010f60318cf2.tar.bz2
askama-9f3b590206e3dfe33b7129b1c8ff010f60318cf2.zip
Move most of the code into new askama_shared crate
This makes it possible to share code between askama and askama_derive.
Diffstat (limited to '')
-rw-r--r--askama_shared/Cargo.toml19
1 files changed, 19 insertions, 0 deletions
diff --git a/askama_shared/Cargo.toml b/askama_shared/Cargo.toml
new file mode 100644
index 0000000..6ad2bff
--- /dev/null
+++ b/askama_shared/Cargo.toml
@@ -0,0 +1,19 @@
+[package]
+name = "askama_shared"
+version = "0.3.4"
+authors = ["Dirkjan Ochtman <dirkjan@ochtman.nl>"]
+workspace = ".."
+
+[features]
+default = []
+serde-json = ["serde", "serde_json"]
+iron = []
+rocket = []
+
+[dependencies]
+error-chain = "0.10"
+nom = "3"
+quote = "0.3"
+serde = { version = "1.0", optional = true }
+serde_json = { version = "1.0", optional = true }
+syn = "0.11"