aboutsummaryrefslogtreecommitdiffstats
path: root/askama_shared/Cargo.toml
diff options
context:
space:
mode:
authorLibravatar David Tolnay <dtolnay@gmail.com>2018-04-12 11:42:36 -0700
committerLibravatar Dirkjan Ochtman <dirkjan@ochtman.nl>2018-04-12 21:14:49 +0200
commit1267e966f47893bdaa9ab0f3f15d32110eddfd6e (patch)
tree0f84c80d1e3bcdff4bdf898a4db4e0da934166e8 /askama_shared/Cargo.toml
parente56a0d034b4cbd146c374366964c6c7f4587539f (diff)
downloadaskama-1267e966f47893bdaa9ab0f3f15d32110eddfd6e.tar.gz
askama-1267e966f47893bdaa9ab0f3f15d32110eddfd6e.tar.bz2
askama-1267e966f47893bdaa9ab0f3f15d32110eddfd6e.zip
Isolate proc-macro dependency to the proc macro
The dependency of askama on askama_shared on syn on libproc_macro used to mean libproc_macro would be dynamically linked into any crate using askama. We want only askama_derive to have a runtime dependency on proc macro. This commit moves all proc macro code from askama_shared into askama_derive so that the askama crate no longer dynamically links libproc_macro.
Diffstat (limited to '')
-rw-r--r--askama_shared/Cargo.toml3
1 files changed, 0 insertions, 3 deletions
diff --git a/askama_shared/Cargo.toml b/askama_shared/Cargo.toml
index 3f7c4b3..d1ef222 100644
--- a/askama_shared/Cargo.toml
+++ b/askama_shared/Cargo.toml
@@ -16,8 +16,5 @@ rocket = []
[dependencies]
error-chain = "0.11"
-nom = "3"
-quote = "0.5"
serde = { version = "1.0", optional = true }
serde_json = { version = "1.0", optional = true }
-syn = "0.13"