aboutsummaryrefslogtreecommitdiffstats
path: root/askama_axum/Cargo.toml
diff options
context:
space:
mode:
authorLibravatar Michael Alyn Miller <malyn@strangeGizmo.com>2021-11-27 20:59:51 -0800
committerLibravatar Dirkjan Ochtman <dirkjan@ochtman.nl>2021-11-27 22:03:18 -0800
commit4940b5dd5e792811491f1c3c3b1c70c8177c7e02 (patch)
tree4d28ad21a66ecf9496c265c0844b4c4d036763bc /askama_axum/Cargo.toml
parent3ef2869f48556a0aae4ca861889f9fd8bea02d66 (diff)
downloadaskama-4940b5dd5e792811491f1c3c3b1c70c8177c7e02.tar.gz
askama-4940b5dd5e792811491f1c3c3b1c70c8177c7e02.tar.bz2
askama-4940b5dd5e792811491f1c3c3b1c70c8177c7e02.zip
Add Axum integration
Diffstat (limited to '')
-rw-r--r--askama_axum/Cargo.toml23
1 files changed, 23 insertions, 0 deletions
diff --git a/askama_axum/Cargo.toml b/askama_axum/Cargo.toml
new file mode 100644
index 0000000..7d3045d
--- /dev/null
+++ b/askama_axum/Cargo.toml
@@ -0,0 +1,23 @@
+[package]
+name = "askama_axum"
+version = "0.10.0"
+authors = ["Michael Alyn Miller <malyn@strangeGizmo.com>"]
+edition = "2018"
+description = "Axum integration for Askama templates"
+keywords = ["markup", "template", "jinja2", "html", "axum"]
+categories = ["template-engine"]
+homepage = "https://github.com/djc/askama"
+repository = "https://github.com/djc/askama"
+documentation = "https://docs.rs/askama"
+license = "MIT OR Apache-2.0"
+workspace = ".."
+readme = "README.md"
+
+[dependencies]
+askama = { version = "0.11.0-beta.1", path = "../askama", default-features = false, features = ["with-axum", "mime", "mime_guess"] }
+axum = { version = "0.3", default-features = false }
+
+[dev-dependencies]
+hyper = { version = "0.14", features = ["full"] }
+tokio = { version = "1.0", features = ["full"] }
+tower = { version = "0.4", features = ["util"] } \ No newline at end of file