aboutsummaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorLibravatar cel 🌸 <cel@blos.sm>2023-02-19 02:11:17 +0000
committerLibravatar cel 🌸 <cel@blos.sm>2023-02-19 02:11:17 +0000
commitc6378ca77f08a8aaf30fa25c4c02d151bf69edfa (patch)
treef3d21a7d15f2543c4ccd2eba505a91774833529c /Cargo.toml
parent0b6d17e87106bb514a62d79d13e8465fd3bffc3a (diff)
downloadblossom-c6378ca77f08a8aaf30fa25c4c02d151bf69edfa.tar.gz
blossom-c6378ca77f08a8aaf30fa25c4c02d151bf69edfa.tar.bz2
blossom-c6378ca77f08a8aaf30fa25c4c02d151bf69edfa.zip
create initial database migration
Diffstat (limited to '')
-rw-r--r--Cargo.toml2
1 files changed, 2 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 9ecda36..417dd4a 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -7,6 +7,8 @@ edition = "2021"
[dependencies]
rocket = { version = "0.5.0-rc.2", features = ["json"] }
+sqlx = { version = "0.5", default-features = false, features = ["macros", "offline", "migrate"] }
+rocket_db_pools = { version = "0.1.0-rc.2", features = ["sqlx_sqlite"] }
reqwest = { version = "0.11", features = ["json"] }
mastodon-async = "1.1"
tokio = { version = "1", features = ["full"] }